How to transfer gpx files to TomTom rider 400?

As title, how to transfer gpx files to TomTom rider 400?

Until recently I was able to transfer gpx files to my TomTom Rider 440 by going online to

which now redirects to

ov2 (POI) files transfer OK but not gpx files

Whats happened here? Has TomTom broke it? Will they fix it?
I can’t find any information anywhere, not even of folk having the same problem, it can’t be just me!

or does anyone have an email address for TomTom customer services?

All they have online is an illiterate bot

emailing [email protected] results in

550 5.4.1 Recipient address rejected: Access denied. [ 2024-02-19T09:17:39.706Z 08DC2C3F29992F14]

Looks like you have to go via their support page

Thanks G but I’ve been there, done that, no joy. It’s an AI bot that replies to every question with “I’m sorry, I don’t understand that question, please try again using different words”.

The troubleshooter is out of date and only refers to ‘My Drive Connect’ which is working because I can update the software and import ov2 (POI) files, I can no longer import gpx (route) files. The wizards have replaced ‘My Drive’ with ‘plan.tomtom’ and it doesn’t work but I can’t find a way of telling them. It’s as if Tomtom is no more.

I’d say they are no longer supporting a discontinued device will be their response if you get hold of anyone.

1 Like

Discontinued? I checked for updates over the weekend and all there was a Western Europe map update.

What is odd is nobody else seems to be having this issue, at least they don’t appear to be any complaints about it.

Export the file and save it to the SD card.

Nope, I’ve already tried that and it doesn’t work. When TomTom Rider wakes up you can press an “Import Routes” iocn, select the tick boxes of the routes on the SD card that you want to import and press the “Import” icon, there’s a brief display of “Importing Routes” followed by “Import Error X None of your selected routes could be imported”

The previous website, mydrive.tomtom, re-wrote the gpx file before downloading it to the TomTom Rider and it all worked smoothly, the new website, plan.tomtom, doesn’t re-write the file into something that TomTom Rider can read, it goes through the motions but nothing is downloaded to the TomTom Rider.

Both download methods, copy from SD card and plan.tomtom, work ov2 (POI) files but not gpx (ROUTE) files. The TomTom wizards appear to have fixed something that wasn’t broken but it is now :frowning:

Found a fix, tried 6 different gpx files and found the Tom Tom Rider can only read gpx TRACKS which means that it can read off the SD card:
Garmin Zumo GPX Basecamp.gpx
GPS eXchange 10. gpx
but not other gpx files such as the Garmin Nuvi GPX MapSource.gpx which I was using earlier.

A little odd having to import *.ov2 files via plan.tomtom and *.gpx via the SD card but there it is a work around for the Tom Tom wizards failing