Problem: Google maps website

I’ve tried Firefox and IE but the Google maps website seems to stop sending data to my browser when I zoom in beyond a certain level and the browser then displays the ‘no map data at this level of zoom’ message. Also, sometimes, even when zoomed out over London, many sections of the map is missing with just a blank square showing that same message.

I know its something wrong here at home as the same level of zoom in the same area of the map can be achieved on my computer at work.

Is it my Internet connection (Pipex) although it works in every other way?

Or is my Belkin router misbehaving?



I know you’ve tried it at work and it works, but it still could be their server. Think about what time of day you check at home, compared to when you check at work. If you check in the evening here, more people are getting home and logging on, or around 4pm here, America wakes up and starts hogging the worlds bandwidth…maybe send an email to their tech support. If you are getting the message of ‘unable to provide blah blah…’ in the squares, it’s more than likely coming from their end. Or they just don’t like your PC.:w00t::wink:

Hadn’t considered that Moley, but then again…I’ve used the website well after 8 in the evening at work and still had it work as quickly as normal…Go figure :crazy:

I think they don’t like my PC as I’ve just connected my phone to the wireless network and run the Google Maps for Windows Mobile application. It runs fine. So it looks like the connection is ok assuming that they use the same server to supply map data.


Mole, did you used to be on UK Bike Forum?..Think I remember your name.

Nah, not me, I used to haunt Computer Music forum as Lbix though…:)One other thing you can look at is do you have a firewall at home? Perhaps if you do, it might be blocking some aspects of the site. Also, check which versions of IE and Firefox you are using.

Another idea is, I think multimap have the same options of satalite now, so you can check out their site too…I’ll double check that and confirm though (I’m at work with nothing better to do!:wink: ) Ok, yup, checked, you have to type in your destination first, and then when it’s loaded there are 3 choices - same as google maps, map, aerial or hybrid. Give that one a go if you fancy :slight_smile: Although - it’s not quite as high def as google maps.